Click Here to Sign Up for Prosperent ←      → Click Here to get the FREE WPProsperent Plugin

WPP Free Plugin

Current version is 1.2.3 Please scroll down to see the info.

You can download the free WP Prosperent below and watch the videos for instructions on how to use it.

WPP Pro users – you will still want to watch the videos as the basics are the same, you just get even more features.  You can find out about WPP Pro here:  http://www.wpprosperent.com/updates/wp-prosperent-pro-here/

If you wish to receive updates about new versions please sign up on the list at the right. ————–>>>>>>>>>>>

If you like the , please let others know about it.

Any problems and you can let me know in the comments below, contact me via the contact page, or send me an email by replying to one of the list updates.  (I don’t like posting emails on open pages).

Thanks

Click to go to the WordPress download page v1.2.1  updated 11/2/10

Video 1a – How to use WPProsperent

Video 1b – How to use WPProsperent

Video 2 – Creating a WPP token

Video 3 – How to add WPP to all posts on a site.

I have moved the videos to youtube.  If you have problems viewing them send me a note.

I have posted a users manual here:  WPP users manual

Here is a sample site using the :

http://dogs.wpprosperent.com/

Updates:
v 1.2.1 11/3/10
-changed query types so more relevant items should be returned.
-added several templates
-added a fix for a rare situation that could casue blog to stop working
-fixed version number typo
-if you were using negatives in your global keyword they will no longer work in this version due to the query change – (sorry)

v.1.1 – 10/10 This is an optional update to add dynamic sid (sub-ID) tracking.

Since the is on the site, you can use the auto-upgrade feature built into WP. Your settings will still be there. If that fails, the easiest way to upgrade is to deactivate the .  Then a delete link will show up under it on the list.  Delete it.  Select the option to remove all files.   Once that is done, install the new version using the add new – upload system.  And activate it.   That should be it.   You can double check your setting but everything should still be there as you had it set.

Things to note:

You don’t have to remove any ads from your sites.

You can click and test the links.  There is no issues with you clicking them.

There is no min CTR or any restrictions.

There is no display restrictions.  You can do anything you want with them as long as you allow the user to click through.

You can buy items you click on from your own pages.  This is not an issue.

If you display ads on your home page you might want to limit the number of posts showing.   If you have the default 10 posts and then have lots of ads in each post, it can load slowly.

Features to be added soon:

Add category name to keyword.

Add more templates.

Current known issues:

Cloaking might not be working with sub-domains. This is not a bug.  Test your links.  If it fails to load the merchants page with cloaking on, turn off cloaking and test again. you need to check and see it you have a .htaccess file.  If you use a custom permalink structure you will have one.  If you use the default permalinks, you might not have one.   You can upload a blank text file to the root of your domain (public_html) and name it .htaccess    There should not be a .txt after it.  Sometimes its easier to upload as a .txt and rename once uploaded.

Popular terms:

  • wp prosperent
  • WP Prosperent
  • wpprosperent
  • Warning: curl_errno(): 2 is not a valid cURL handle resource
  • prosperent
  • prosperent api templates free download
  • WP Prosperent Pro
  • wp prosperent cloaking
  • wp mage v1 2 3
  • WP-Prosper download

Related Posts

{ 96 comments… read them below or add one }

Charles - admin November 9, 2010 at 4:54 pm

Glen, comcast bounced the reply I sent you so here it is:

Nice page.
I don’t see anything wrong with it. Am I missing something?

Glenn November 9, 2010 at 8:07 pm

That’s weird. Now with different products showing, the grid alignment is OK. Oh well everything works.

One thing I noticed is that there was a sorting drop down box setting in the previous version of the plug in but not in the new one. Why was it removed?

Charles - admin November 9, 2010 at 11:21 pm

Glenn, I have notices a few items with really long titles and with really only vendor names can throw of the grid a little.

The free version was changes to make it easier to use. Prosperent has two search modes and the “standard” one (which I call the super optimized one) which should return better targeted items most of time doesn’t allow for sorting or other things. I didn’t find that sorting was very helpful anyways.

The Pro version coming really soon will allow people to use the extended version but its a “raw” search and the targeting is off many times. I left it there as an option and therefore left in the sorting options that can be used with it. I don’t plan on using it.

Charles November 10, 2010 at 1:26 pm

Hi Charles,

When I type in a query into my website’s search box for a specific brand name I’m not showing the term I searched for. I’m receiving a different brand name in the same product line.
Also, how can my website be interactive with not just TCPA ads, but with the WP Prosperent Product Search, i.e. http://www.wpprosperent.com/products/beds when searching on MY site? I’m a Mage user.

Thanks,

Please advise.

Charles - admin November 10, 2010 at 2:09 pm

Hi Charles,

You are using my store script? If so, please use the contact page to email me and we can figure out what is happening.

If you are using the WPP plugin and want it to do something similar to what you see at http://www.wpprosperent.com/products/beds.html then the free version can’t do that. WPP Pro will have the ability to run searches within your WP site. It’s coming soon.

Glenn November 13, 2010 at 11:06 am

Do you have code examples (and what thy look like on a page) on how to use all the new templates you’ve added like:

[wpp keyword="KEYWORDS" template="grid" limit_page="20"]

Glenn November 13, 2010 at 12:20 pm

Can you show me how to do a query for only Video Game for different systems? I tried the following but returns accessory products to.

[wpp keyword="Wii Video Games" template="grid" limit_page="12"]
[wpp keyword="Xbox 360 Video Games" template="grid" limit_page="12"]

etc.

Hajo November 13, 2010 at 4:49 pm

Hi Charles,

I have a blog with around 130 posts.
When I use the Post Layout plugin, the prosperent ads show only on some of my posts, but on many they don’t.
Is this a common phenomenon? And is there a strategy to avoid this?

Thanks a lot for your help,
Hajo

Charles - admin November 13, 2010 at 5:58 pm

Glen, I have a sample with some of the templates here: http://dogs.wpprosperent.com/dog-beds/

As for video games only… don’t know. You have to play with the searches. Perhaps a negative for the word accessories. It all depends on what data the vendors have in there.

Charles - admin November 13, 2010 at 6:00 pm

Hajo, The only time ads wont show is if the query produces zero results. If you want to see what the real query is for that page temporarily turn on the debug mode and it will show the query.

Victor Palmer November 15, 2010 at 12:32 pm

Charles

I don’t know if you could take a look at my site but I seem to have a lot of code appearing before my products. This has also appeard on a couple more of my site.
Can you tell me how I can get rid of it and how to prevent it from happening on other sites I might build.

Charles - admin November 15, 2010 at 1:24 pm

That is the debug info. Uncheck the debug mode.

Glenn November 15, 2010 at 3:56 pm

I had to put the W3-TOTAL-CACHE plug-in on many of the sites I have your prosperent plug-in on.

Do you know if this effects the products retrieved for display?

Or for that matter if it effects products displayed using phpBay?

Charles - admin November 15, 2010 at 4:00 pm

I have it on about 400 sites that also have my plugin and phpbay. Works fine. Just remember to clear the cache after you make changes with plugins or site layout.

Glenn November 15, 2010 at 4:16 pm

OK. Charles. That put’s me at ease. On last thing about that. Can you tell me the general settings you have for the W3-Total-Cache? Hostgator told me to use the following general settings which I did.

Page Cache Enable: Checked
Page Cache Method: Disk (enhanced)
Minify Enable: Checked
Minify Cache Method: Disk
Database Cache Enabled: Checked
Database Cache Method: Disk
Object Cache Enable: Checked
Object Cache Method: Disk
CDN Enable: UN-Checked
Browser Cache Enable: UN-Checked

Charles - admin November 15, 2010 at 4:20 pm

That looks fine. On 90% of mine, I just used the preset settings.

Glenn November 16, 2010 at 5:54 pm

I have the plug-in code on a page but the products don’t change. I deleted the temp. page cache and refreshed the page but products don’t change. Aren’t they supposed to change?

Charles - admin November 16, 2010 at 6:21 pm

On any single page, no the items shouldn’t change unless you changed the settings (or post title, etc). Its designed to try to target items for that page. So if you go to a different page you should see different items.
See my sample site here: http://dogs.wpprosperent.com/

Glenn November 17, 2010 at 10:08 am

This is not so totally related but would help me out a lot.

I’m installing W3-TOTAL-CACHE on a bunch of sites. When you installed it on WPMage blogs, did you change any settings or do you just install and activate the plug-in?

Thanks,
Glenn

Charles - admin November 17, 2010 at 1:12 pm

No, I didn’t make any changes.

Glenn November 17, 2010 at 5:41 pm

How can I have the plug-in return new products everytime a user goes to the page.

I want the products to be new everytime.

Glenn November 19, 2010 at 2:55 pm

This plug-in is wreaking havoc on a few sites I have it on.

I have the following code template [wpp template="grid" limit_page="15"] added to after the post content using Post Layout plug-in and clicked on any blog post and NO CONTENT displayed. I then deleted the [wpp template="grid" limit_page="15"] code from post layout and everything was normal again.

I have the code on another site on the main blog page and it too had problems loading. As soon as I removed the code everything was normal.

Charles - admin November 19, 2010 at 3:46 pm

Glenn,
It sounds like there is a plugin conflict.
I know this plugin does work and I have hundreds of users using it with no other reported issues.

The only time have ever seen content disappear from my sites was way before this plugin was created. It was when link mage was active on my sites. I wasnt even using it, but just having it active killed a lot of content. Once I turned it off everything was back to normal. This is a plugin from WP Mage. Do you have this on your blogs?

If not, there is most likely another plugin conflicting for some reason.
But there is no way I can determine what it is, unless you want me to take a look inside one of your blogs. If you want to email me a blog and admin access I can look. I will have to temporarily make changes to the plugs to see what is happening.

Glenn November 19, 2010 at 7:00 pm

Yes. I have Link Mage active and like Link Mage. I haven’t made a dime from this network so I’m not going to pursue this any more. Looked like a good EBay equivalent.

Glenn November 20, 2010 at 12:28 pm

I still have it a couple sites on Hostgator it working on but this one. Coolhandle forget it.

Now on 1 site on a separate Hostgator account I’m getting this error twice. What does this mean?

Warning: curl_error(): 195 is not a valid cURL handle resource in /home/glennfr/public_html/wp-content/plugins/wpprosperent/library/Prosperent/Api.php on line 340

Warning: curl_errno(): 195 is not a valid cURL handle resource in /home/glennfr/public_html/wp-content/plugins/wpprosperent/library/Prosperent/Api.php on line 340

Here is the code that’s causing it.

Charles - admin November 20, 2010 at 1:14 pm

just to make sure are you using the latest versions…. free is 1.2.1 pro is 1.5.3

If you are I will have to get back to you later on this.
Another user also just reported it.

I have 6+ hosts and numerous different servers from shared to dedicated including coolhandle and hostgator, and I haven’t seen this error yet or encountered any other issues.

Another quick check you can try, to see if it is hosting or wp would be to turn off all plugins except wpp and post layout if htat is what you use to display it.
See if it works. If does, then its a wp plugin conflict. If not, then it might be server settings. Then turn back on all other plugins and turn off wpp again.
This should only take one minute to do.

Glenn November 20, 2010 at 1:51 pm

That’s really weird. I just checked the page again and it works.

I went to the page in the morning, it worked. Then late morning got that error. Now mid-afternoon it’s working good on my Hostgator account site.

Charles - admin November 20, 2010 at 4:20 pm

I wrote a reply earlier but my system is being wacky and it didn’t post. When checking for another issue we figure this one out. It was an error in the API code Prosperent gives us to “talk” to them. It only will show the error you saw when our code can’t connect to their server (meaning, if they are down or running really slow). This is a rare case so it didnt show up before and the code we had in place for this instance didnt fully bypass the issue.

A new version will be uploaded shortly which will solve the problem.

Hajo November 21, 2010 at 2:28 pm

Hi Charles,

The problem is ongoing.

My webpages still show same line as Glenn has stated before (…Api.php on line 340) instead of posts when the plugin is activated.
I deactivate the plugin until a solution can be found.

Regards,
Hajo

The only choice for me was to deactivate the prosperent plugin for the time being.

Charles - admin November 21, 2010 at 7:30 pm

Hi,

If you are talking about the curl error, I said is was and a new version was uploaded to WP. Please upgrade to v 1.2.2.
If you are a pro user and need this fix, please email me. I will be sending out the update soon.

If this is about any other error, I will need to see it on a blog to try to solve it.

Thanks

Glenn November 22, 2010 at 1:46 pm

Where is 1.2.2? don’t see it.

Charles - admin November 22, 2010 at 1:54 pm

download is here: http://wordpress.org/extend/plugins/wpprosperent/
its the link in the post above.

or you can use the WP auto-updater inside any wp-admin where you already have it installed.

Stef November 23, 2010 at 2:28 am

Cool stuff Charles.

Any release date for the Pro Version, and what will be the tag price?

Thank you,
Stef

Charles - admin November 23, 2010 at 1:07 pm

Well, the plugin is done and ready – now Im adding coupons :)
But I have any instructions done. I wanted to do that before releasing it.

“tag” price – the highest it would go at the current time would be $27, but I do plan on running specials for much less. :)

Stef November 24, 2010 at 4:40 am

Thank you Charles, it sounds great.
Christmas isn’t far, it would be great to get it very soon. :-)

Stef

Kim December 18, 2010 at 8:12 am

Charles, no products showing up on search results page??

Charles - admin December 18, 2010 at 6:46 pm

Assuming that Prosperent isn’t down it should work if you have your API key installed.
A quick way to check is use the debug mode and a common word just to see what happens.
On the right menu here, you should see a link to the manual. I have a video on the debug mode there.

Kim December 18, 2010 at 10:58 pm

Thanks Charles – it was the Wordpress SEO plugin that caused it – had to deactivate that one.

New issue: Storebuilder script is giving a Error 404 not found.
Script is on subdirectory on a WP install
Already did the change in .htaccess.

Work fine on another site on a different server though :(

Kim December 18, 2010 at 11:14 pm

Charles, what are the server requirements as nothing seem to work on this server …

Charles - admin December 19, 2010 at 1:24 am

Hi Kim,

I don’t have specific server requirements. I guess the absolute based would be php. If it can run WordPress it should work. The biggest issue is when companies don’t don’t use the same standards and have weird systems that mess up the url rewriting in the .htaccess. This happens with 1and1 and godaddy. Not sure about others. I have it working fine with hostgator, liquidweb/storm, and other standard cpanel hosts.

Use the contact form to send me your url and host.

Thanks
-Charles

Glenn January 6, 2011 at 6:52 pm

I’m a Master Mage of the WPMage system and learned today that Amazon & Overstock affiliates will be terminated if they live in Illinois (which I do) and Gov. Patt Quinn passes the “Amazon Tax” bill.

The question is, are you Charles or anyone else earning revenue from the Prosparent network? Many Master Mages have tried this system & plug-in and earned nothing or very little. I too see not income but only have it on a couple main blog pages to show products on the front page.

Thanks and please tell me the real truth about this system. And if I replace it and it works pass it on to other mages.

I’m asking because I may have to use it to replace my Amazon/Overstock income.

Charles - admin January 6, 2011 at 11:01 pm

Hi Glen,

It can and does work. I had an OK month last month.
I don’t think that a pure mage site will have targeted keywords that work well for Prosperent. My sites are mostly started with mage and then use better keywords (titles) with continued postings. But even they aren’t highly targeted.

For this to be really effective you need to have highly targeted “buyer” traffic.

PS, as for Amazon, at this point its only a warning that it might happen. And you can “move” your business address to another state very easily.

CN April 30, 2011 at 11:38 am

I came here looking for troubleshooting / help because my datafeeds had all disappeared from my site and I’d tried a few things to sort it out myself. On switching into debug mode, I discovered that my credentials and API key were ‘invalid’. Just thought I’d let people here know before they go to a lot of trouble doing the same that prosperent had a crash. They’re working on reimporting the catalogues and other data as of now, but it doesn’t appear they’ve been able to restore all the existing user accounts, tho they have a plan and say no commissions are at risk. Visit the Prosperent forum for all the dirt on that.

Charles, can you tell us whether this will have any effect on our plugins and settings? Or should everything revert to pre-crash status once our accounts are reactivated by Prosperent?

Charles - admin May 1, 2011 at 2:54 pm

Im in the dark as much as you. None of my ads are showing on all the sites I checked even though they saw they are back “up” now. My accounts shows impresses and clicks but I have not idea where they are coming from.

You would need to ask on the forum or directly to them.

Glenn May 11, 2011 at 10:15 pm

I only have 2 web sites with prosperent plug-in on them and none of the ads show up.

What’s going on?

Charles - admin May 11, 2011 at 11:26 pm

Prosperent had some major issues and it wiped all the accounts. All the info is in their forums.
The short – you need to go back to their site and see if you can log in.
If not, you need to re-sign up.
log in and create a new api key.
Then you can take the api code from within your wpp settings and paste that on top of new api key. This will like your old key back to your account.

Any further questions should be asked on their forums as they would be able to help better.

Leave a Comment